Jump to content


Photo

Incorrect date format


  • Please log in to reply
8 replies to this topic

#1 joeh

joeh

    Newbie

  • Members
  • Pip
  • 7 posts
  • LocationMelbourne, Australia

Posted 29 October 2012 - 03:10 PM

I've just purchased Due Today as it looked quite promising, but one annoying problem is that dates are displayed in U.S. format rather than international format. My locale is set to English (Australia) which should be d/m/y.

Three places I see this:

1. Task list (shows 1 November as 11/1 which to me looks like 11 January).

2. Task summary (shows "Due November 1, 2012" which should be "Due 1 November 2012" but less important due to month being spelled out.

3. Date button in notes edit (inserts Nov 1, 2012 9:07:50 AM) which I thought was fixed in the latest release, but this is also less important due to month being spelled out.

Any chance of a fix?

#2 Peter Bulthuis

Peter Bulthuis

    Advanced Member

  • Members
  • PipPipPip
  • 47 posts
  • LocationThe Netherlands

Posted 29 October 2012 - 03:22 PM

Strange, I don't have that problem. Try the main settings of your Android device. Search for Date and Time.

#3 joeh

joeh

    Newbie

  • Members
  • Pip
  • 7 posts
  • LocationMelbourne, Australia

Posted 29 October 2012 - 04:15 PM

Settings - Date and time shows:

Select date format: DD/MM/YYYY

which is correct, but not what Due Today is showing. (Android 4.0.3 on a Samsung Galaxy S II.)

Interestingly, just noticed the widget is correctly showing "1 Nov", but the app is still showing "11/1".

#4 Chris

Chris

    Administrator

  • Administrators
  • 337 posts
  • LocationUtah

Posted 01 November 2012 - 10:26 AM

The weird part is that I'm retrieving the date format using the current locale. I know I can get it to work on the emulator. I'll try one more time today to see if I can figure it out. Otherwise, I may just add an option to let you select the date format shown. That might be the easiest way to go.

#5 jmk

jmk

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 11 November 2012 - 03:20 AM

Not that I'm expecting it to have been dealt with already, but just so you know, following the 11/10 update (or 10/11 in my part of the world ;-) ) I'm still getting "American" dates like joeh.

#6 Chris

Chris

    Administrator

  • Administrators
  • 337 posts
  • LocationUtah

Posted 20 November 2012 - 12:57 AM

I've been making some adjustments today to try to make this work better.

#7 joeh

joeh

    Newbie

  • Members
  • Pip
  • 7 posts
  • LocationMelbourne, Australia

Posted 14 January 2013 - 07:03 PM

Either yesterday's update, or the firmware update I got last week, have resolved this problem for me. Chris, if it was you, thanks very much!

#8 Chris

Chris

    Administrator

  • Administrators
  • 337 posts
  • LocationUtah

Posted 19 January 2013 - 01:13 AM

No problem. Of course, I see this after I start implementing the ability to choose the date format. :)



#9 Peter Bulthuis

Peter Bulthuis

    Advanced Member

  • Members
  • PipPipPip
  • 47 posts
  • LocationThe Netherlands

Posted 26 January 2013 - 02:32 PM

Is it possible to add in the new Editor Date Format the date format 1 maart 2013.

Now, there's no way for me to choose that one. I can choose March 1, 2013 etc. but no 1 March 2013.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users