Jump to content


Photo

Version 2.1.12.743 Not Working


  • Please log in to reply
2 replies to this topic

#1 Jim

Jim

    Member

  • Members
  • PipPip
  • 28 posts

Posted 05 May 2014 - 11:45 AM

After updating to the latest version on Google play (2.1.12.743) from version (2.1.5) the program would freeze every time I tried to start it. Not completely a blank screen but frozen one within due today with no menus or anything working. I uninstalled and reinstalled to see if that would help and that gave me a working interface initially but when I tried to restore my database from backup the program would try but then eventually hang during the restore process and ultimately result in an ANR error every time I tried.

 

I tried a factory reset to rule out a problem with the phone but the same thing still happened. The restore from backup hangs at some percentage into the process and the ANR error happens no matter how many times I choose wait or try the restore again. I also tried to restore earlier backups to rule out a corrupt database for the most recent backup but that didn't make any difference, same problem.

 

I also tried the current apk (2.1.12) from the Lakeridge site to make sure it wasn't something with Google Play but same problem.

 

The only solution that has worked was to try the earlier revisions from the previous versions page and the latest revision that doesn't cause the same problem is version 2.1.8 from that page. My phone shows it as 2.1.8.730 installed. Anything later than that one causes the problem I described.

 

Any ideas Chris?

     



#2 Chris

Chris

    Administrator

  • Administrators
  • 337 posts
  • LocationUtah

Posted 07 June 2014 - 01:39 AM

I'm sorry about the delay. The 2.1.12 version introduced an infinite loop in the repeat logic. Version 2.1.13 should have fixed that and was released after this post was made (again, I'm sorry about not getting back to the forums earlier). Did that version ever resolve the issue for you?



#3 Jim

Jim

    Member

  • Members
  • PipPip
  • 28 posts

Posted 09 June 2014 - 08:07 AM

I was able to update from the 2.1.8 version to 2.1.13 without a problem. Thanks for keeping the previous versions page active, being able to sideload the earlier version was the only thing that saved me until 2.1.13 was released.

 

If anyone is looking for the previous versions page, Chris provided this - 

 

I already do have the previous versions available on my site. However, they are the versions that require a license since you will be downloading it outside of the Google Play store.

You can find them here:
http://www.lakeridge...evious/DueToday

If you need a license code, please let me know via email and I'll look up your purchase and get you a code.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users