Jump to content


Photo

why task_notes can only use English ?


  • Please log in to reply
6 replies to this topic

#1 sqhua

sqhua

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 30 August 2013 - 01:52 AM

I use chinese string for task_name,and then it can send to server .

 

but if I use chinese string for task_notes,App will close, and "Lakeridge Software Bug Reporter"  will show.

 

can you fix it in next release version ? thanks a lot



#2 sqhua

sqhua

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 30 August 2013 - 01:58 AM

for example :

 

黄(10604)  16:42:43
我已经签入了吧
秦(42379)  16:43:15

彭(3216)  16:43:16
求ld一直签出
黄(10602)  16:45:29
LD=领导
彭(3216)  16:45:46
LD=老大
巍(84472)  16:50:42
LD=老弟



#3 Chris

Chris

    Administrator

  • Administrators
  • 337 posts
  • LocationUtah

Posted 04 September 2013 - 02:56 PM

The notes component I'm using is supposed to be fully Unicode compliant. I've tested it with Russian characters with great success. I'll test it with the notes you provided tonight and see if I can figure out why it's crashing. Thank you for letting me know.

#4 sqhua

sqhua

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 05 September 2013 - 09:12 PM

thanks Chris

 

I use sniffer tools monitor the net tran,then found the title and notes isn't same encoding by the same source。I suspect problem can fix while use title_control to replace notes_control.



#5 Chris

Chris

    Administrator

  • Administrators
  • 337 posts
  • LocationUtah

Posted 10 September 2013 - 01:24 PM

That might actually be a source of the duplicate tasks, too. Thanks for looking into that.



#6 sqhua

sqhua

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 28 October 2013 - 03:01 AM

the bug still not fix in Ver1.81.....

 

if the note like then:

 

黄(10604)  16:42:43
 我已经签入了吧
 秦(42379)  16:43:15
 
彭(3216)  16:43:16
 求ld一直签出
 黄(10602)  16:45:29
 LD=领导
 彭(3216)  16:45:46
 LD=老大
 巍(84472)  16:50:42
 LD=老弟
 



#7 Chris

Chris

    Administrator

  • Administrators
  • 337 posts
  • LocationUtah

Posted 08 November 2013 - 02:38 AM

I double-checked all of my code and I'm not sure why it's not happening. I copied and pasted the text directly from your post and it synced to my phone correctly using all of the same characters.

 

Also, the notes and subject field are using the same code, string types, encoding patterns, etc. They are even using the same code page for text formatting. So, at this point I'm not sure why it's not working properly for you. The only thing I can think of is that my browser converted everything over nice and neat so when I copied the text I didn't get it in the same format that you see when you enter the text directly into ToodleDo.

 

So, I have an idea. Can you create a text file with the above note text in it and then send it to me via email, please? That way it won't go through any sanitation code provided by my browser (I've tried Chrome, FireFox and IE10). So it should be encoded exactly as it appears on your computer. Then I might be able to get a proper test.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users